Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie działa plugin(server_cmd)


  • Zamknięty Temat jest zamknięty
1 odpowiedź w tym temacie

#1 Niquit

    Zaawansowany

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:114
  • Lokalizacja:Szczecin
Offline

Napisano 17.07.2013 11:19

Witam,

kiedyś napisałem plugin do ustalenia ilości botów. Pewnego razu przestał działać(może aktualizacja binarek, nie wiem)

/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#define PLUGIN "Bots Limit"
#define VERSION "1.0"
#define AUTHOR "Niquit"
 
public plugin_init()
{
register_plugin(PLUGIN, VERSION, AUTHOR)
set_task (1.0, "Boty", 0, "", 0, "b", 20)
}
 
public Boty()
{
if(player_count() == 1)
server_cmd("pb_maxbots 2")
server_cmd("pb_minbots 2")
server_cmd("pb_bot_quota_match 0/2")
}
else if(player_count() == 2)
{
server_cmd("pb_maxbots 1")
server_cmd("pb_minbots 1")
server_cmd("pb_bot_quota_match 0/1")
}
else if(player_count() >= 3)
{
server_cmd("pb_maxbots 0")
server_cmd("pb_minbots 0")
server_cmd("pb_bot_quota_match 0/0")
server_cmd("pb removebots")
}
else
{
server_cmd("pb_maxbots 3")
server_cmd("pb_minbots 3")
server_cmd("pb_bot_quota_match 0/3")
}
}
 
public player_count() 
{
new iPlayers[32], iNum, count
get_players(iPlayers, iNum)
for(new i=0;i<iNum;i++)
{
if(is_user_connected(iPlayers[i]) && !is_user_bot(iPlayers[i]) && is_user_hltv(iPlayers[i]))
{
count++
}
}
return count
}
 
Wcześniej to działało i nie wiem co jest przyczyną.
 
Poniżej ostatni kod, który napisałem i coś tam już działał, ale dopiero jak ręcznie wpisałem w konsole np. "amx_cvar pb_maxbots"
/* Plugin generated by AMXX-Studio */
#include
#include
#define PLUGIN "Bots Limit"
#define VERSION "1.0"
#define AUTHOR "Niquit"

public plugin_init()
{
register_plugin(PLUGIN, VERSION, AUTHOR)
}

public player_count()
{
new iPlayers[32], iNum, count
get_players(iPlayers, iNum)
for(new i=0;i {
if(is_user_connected(iPlayers[i]) && !is_user_bot(iPlayers[i]) && !is_user_hltv(iPlayers[i]))
{
count++
}
}
return count
}

public client_authorized(id)
{
if(player_count() == 1)
{
set_cvar_num("pb_minbots", 2)
set_cvar_num("pb_maxbots", 2)
set_cvar_string("bot_quota_match", "0/2")
}
else if(player_count() == 2)
{
set_cvar_num("pb_minbots", 1)
set_cvar_num("pb_maxbots", 1)
set_cvar_string("bot_quota_match", "0/1")
}
else if(player_count() >= 3)
{
set_cvar_num("pb_minbots", 0)
set_cvar_num("pb_maxbots", 0)
set_cvar_string("bot_quota_match", "0/0")
server_cmd("pb removebots")
}
else
{
set_cvar_num("pb_minbots", 3)
set_cvar_num("pb_maxbots", 3)
set_cvar_string("bot_quota_match", "0/3")
}
}

public client_disconnected(id)
{
if(player_count() == 1)
{
set_cvar_num("pb_minbots", 2)
set_cvar_num("pb_maxbots", 2)
set_cvar_string("bot_quota_match", "0/2")
}
else if(player_count() == 2)
{
set_cvar_num("pb_minbots", 1)
set_cvar_num("pb_maxbots", 1)
set_cvar_string("bot_quota_match", "0/1")
}
else if(player_count() >= 3)
{
set_cvar_num("pb_minbots", 0)
set_cvar_num("pb_maxbots", 0)
set_cvar_string("bot_quota_match", "0/0")
server_cmd("pb removebots")
}
else
{
set_cvar_num("pb_minbots", 3)
set_cvar_num("pb_maxbots", 3)
set_cvar_string("bot_quota_match", "0/3")
}
}
 
Plugin po prostu nie wykonuje/nie zmienia komend.

Użytkownik Niquit edytował ten post 17.07.2013 11:37

  • +
  • -
  • 0

#2 Gość_21977_*

  • Gość

Reputacja: 0

Offline

Napisano 17.07.2013 15:51

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Temat zamknięty na prośbę użytkownika.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych