Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Problem Cod (Awanse)cod awanse

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
11 odpowiedzi w tym temacie

#1 koong

    Profesjonalista

  • Użytkownik

Reputacja: 89
Zaawansowany

  • Postów:209
  • Imię:Dominik
  • Lokalizacja:Poznań
Offline

Napisano 25.01.2013 20:47

Mam problem, otóż w QTM CodMod.sma pododawałem wszystko jak trzeba według tego poradnika >> http://amxx.pl/topic...63-awanse-klas/ compiluje i wszystko pięknie się skapilowało wrzuciłem na serwer i można wybrać do gry tylko klasy zwykłe i premium a awanse nawet się nie wyświetlają, gdy wpisze /klasy to w opisach są
Co jest nie tak? :>

  • 0


  • +
  • -
  • 0
b_350_20_3A3A3A_3A3A3A_F19A15_111111.png

#2 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 25.01.2013 20:58

Bo awanse odblokowują się po wbiciu danego levela który ustawiłeś w klasie. Wszystko jest tak jak być powinno.
  • +
  • -
  • 1

#3 SlajD.

    Zaawansowany

  • Zbanowany

Reputacja: 12
Początkujący

  • Postów:149
  • Lokalizacja:Warszawa
Offline

Napisano 25.01.2013 21:54

Powiedzmy ze awans masz od 40 lvla na np snajperze . Po wbiciu 40 lvl pojawi ci sie np PRO Snajper . Po to to widac w /klasy zeby garcze mogli sobi zoabczyc co dalsza klasa ma na innym awansie za dodatek !
Dołączona grafika

#4 koong

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 89
Zaawansowany

  • Postów:209
  • Imię:Dominik
  • Lokalizacja:Poznań
Offline

Napisano 25.01.2013 22:48

Dobra, dobra to już wiem jak działa , tyle że klasy mają dziwne błędy robiłem w klasie eliminator rozrzutu a ma eliminator i moduł odrzutowy. itp takie głupie. i Lvl i ranga klasy sie sie nie zapisuje np awansowalem na elitarnego snajpera wyjde z serwera wejde i mam ten sam lvl tylko na klasie Snajper, a czasami w ogóle lvl się nie zapisuje
ale dzięki panowie Macie po "+"

Użytkownik koong edytował ten post 25.01.2013 22:51

  • +
  • -
  • 0
b_350_20_3A3A3A_3A3A3A_F19A15_111111.png

#5 SlajD.

    Zaawansowany

  • Zbanowany

Reputacja: 12
Początkujący

  • Postów:149
  • Lokalizacja:Warszawa
Offline

Napisano 26.01.2013 00:35

klasy sa zle napisane i to dlatego maja inne dodatki , a co do resetu lvli moze to psuc jak plugin , w moim wypadku byly to frakcje
Dołączona grafika

#6 Piro_0

    Zaawansowany

  • Zbanowany

Reputacja: 16
Początkujący

  • Postów:104
  • Imię:Marcin
  • Lokalizacja:Kartuzy
Offline

Napisano 26.01.2013 05:23

zrób zapis lv na nick :D

Pomogłem Daj + Nie Bądź Żyła.


#7 koong

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 89
Zaawansowany

  • Postów:209
  • Imię:Dominik
  • Lokalizacja:Poznań
Offline

Napisano 26.01.2013 11:55

SlajD ja nie mam wgranych Frakcji

Piro mam chyba ustawiony zapis na nick ale zaraz sprawdzę.
macie"+"
  • +
  • -
  • 0
b_350_20_3A3A3A_3A3A3A_F19A15_111111.png

#8 koong

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 89
Zaawansowany

  • Postów:209
  • Imię:Dominik
  • Lokalizacja:Poznań
Offline

Napisano 26.01.2013 14:18

no tak jak mówiłem mam zapis na nick tyle że problem leży w tym klasa awansuje po wbiciu 50 lvla
Gram Snajperem i wbiłem 52 lvl tak jak na zdjęciu niżej.
Dołączona grafika

gdy wpiszę /klasa to na snajperze dalej mam 1 lvl,
Dołączona grafika
Dołączona grafika


a przy wybieraniu klas nie ma wyświetlonych klas Profesjonalny, Elitarny, Kozacki

i gdy wyjdę z serwera i wejdę to nie mogę ich wybrać..
dodam, że jak jakąś klasa wbije lvl poniżej 50 to lvl sie zapisuje

SlajD albo ktoś ogarnięty coś poradzi?:>
  • +
  • -
  • 0
b_350_20_3A3A3A_3A3A3A_F19A15_111111.png

#9 Piro_0

    Zaawansowany

  • Zbanowany

Reputacja: 16
Początkujący

  • Postów:104
  • Imię:Marcin
  • Lokalizacja:Kartuzy
Offline

Napisano 26.01.2013 14:33

W sma tej twojej klasy (po awansie)
cod_regist
powinien wyglądać tak.

cod_register_advance(cod_get_classid("Snajper"), 52, nazwa, opis, bronie, zdrowie, kondycja, inteligencja, wytrzymalosc);

Pomogłem Daj + Nie Bądź Żyła.


#10 koong

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 89
Zaawansowany

  • Postów:209
  • Imię:Dominik
  • Lokalizacja:Poznań
Offline

Napisano 26.01.2013 15:06

.sma klasy według mnie dobre jest.
#include <amxmodx>
#include <codmod>
#include <hamsandwich>

#define DMG_BULLET (1<<1)
new bool:ma_klase[33];
new const nazwa[] = "Profesjonalny Snajper";
new const opis[] = "200 procent obrazen z AWP(+inteligencja), 1/2 szansy na natychmiastowe zabicie z noza(PPM)";
new const bronie = 1<<CSW_DEAGLE | 1<<CSW_AWP;
new const zdrowie = 35;
new const kondycja = 35;
new const inteligencja = 20;
new const wytrzymalosc = 10;
public plugin_init()
{
register_plugin(nazwa, "1.0", "QTM_Peyote");

cod_register_advance(cod_get_classid("Snajper"), 50, nazwa, opis, bronie, zdrowie, kondycja, inteligencja, wytrzymalosc);
RegisterHam(Ham_TakeDamage, "player", "TakeDamage");
}
public cod_class_enabled(id)
{
ma_klase[id] = true;

	  
}
public cod_class_disabled(id)
ma_klase[id] = false;
public TakeDamage(this, idinflictor, idattacker, Float:damage, damagebits)
{
if(!is_user_connected(idattacker))
  return HAM_IGNORED;

if(!ma_klase[idattacker])
  return HAM_IGNORED;

if(damagebits & DMG_BULLET)
{
  new weapon = get_user_weapon(idattacker);

  if(weapon == CSW_KNIFE && damage > 20.0)
   cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
  
  if(weapon == CSW_AWP)
   cod_inflict_damage(idattacker, this, damage*0.5, 0.5, idinflictor, damagebits);
}

return HAM_IGNORED;
}

no i o co może chodzić?

Użytkownik koong edytował ten post 26.01.2013 15:08

  • +
  • -
  • 0
b_350_20_3A3A3A_3A3A3A_F19A15_111111.png

#11 Piro_0

    Zaawansowany

  • Zbanowany

Reputacja: 16
Początkujący

  • Postów:104
  • Imię:Marcin
  • Lokalizacja:Kartuzy
Offline

Napisano 26.01.2013 15:52

Może coś w silniku poknociłeś spróbuj z tym.

Załączone pliki


Pomogłem Daj + Nie Bądź Żyła.


#12 koong

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 89
Zaawansowany

  • Postów:209
  • Imię:Dominik
  • Lokalizacja:Poznań
Offline

Napisano 26.01.2013 16:20

Też nie działa ;(
@@ edit//

Już naprawiłem można zamknąć.

Użytkownik koong edytował ten post 26.01.2013 16:44

  • +
  • -
  • 0
b_350_20_3A3A3A_3A3A3A_F19A15_111111.png





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych